main
members
work
about me
avatar
Paul(admin)
post

Diagnose connection problems in Internet Explorer

Post replyCan't edit post
Watch topicCan't delete post
Friday, December 19 2008, 16:22
Connection problems in Internet Explorer are fairly difficult to diagnose, despite the convenient "Diagnose Connection Problems" wizard that displays when a page fails to load. There are some reasons IE can't connect that won't show up after the wizard completes, so here are some pointers.
First, make sure your internet connection is working by using a proper web browser such as Firefox, Opera, Safari or SeaMonkey.
If you can open pages in other browsers without problems, but Internet Explorer is giving problems, follow the steps below. These solutions may concern you if you are receiving the following message:
Internet Explorer cannot display the webpage
Internet Explorer reports 'Internet Explorer cannot display the webpage'
A Windows Update or add-on may be causing connection problems in Internet Explorer

Check Windows Updates

This may sound silly, but check if you have rebooted your machine after finishing any updates. In some cases, IE is blocked or stops working until a reboot is performed.
You might also want to check for new updates that affect Internet Explorer, and reboot if you install any.

Turn off your anti-virus / firewall / network software

Make sure your anti-virus or firewall programs aren't blocking access to the Internet. If they are, consult the developer's website for a solution.
A network guardian such as PeerGuardian, PeerBlock or NetLimiter may be restricting HTTP access. Check whether you have anything of this sort running.

Check third-party add-ons

You can easily disable all add-ons by starting Internet Explorer with the following command:
iexplore -extoff
Run this command by hitting Windows Key + R on your keyboard to open the "Run..." dialog, then entering the command and pressing OK.
Make sure any instances of Internet Explorer are closed and that the iexplore.exe and ieuser.exe processes are actually terminated in the Task Manager before starting it in this mode. You should get a message that add-ons are disabled.
If the connection is working fine, then one of your add-ons is messing something up. In my case, Orbit Grab++ was messing up my connection. You can disable the third-party add-on by going to Tools then Internet Options. Open the tab Programs, then click Manage add-ons. From that list, you can look around for a problematic add-on and disable it. Restart Internet Explorer in normal mode to see if it fixed the problem.

Clear the cache

Just to make sure that the cache isn't causing the problem, clear it out. Go to Internet Options again, and hit the Delete... button on the General tab, under "Browsing history". Then click "Delete files..." to remove all the Temporary Internet Files. (This won't delete your session data, passwords, etc.)

Proxy connection

If all else fails, make sure that your proxy connection (if you need one) is set up identically to the functioning browser. Unless your internet connection passes through another machine in your household, you typically don't need this set up and it will only cause problems. In that case, make sure it's switched off in the LAN settings of Internet Options, under the Connections tab.

Once you're done using Internet Explorer, reward yourself by quickly resorting back to Firefox.
Rating:
Actions:Post replyWatch topic
No comments.Post reply

More updates

Click here to read more news items.
Members have extra privileges. You can login or register.
© 2005–2017 P. F. Lammertsma
No members currently online; 326 hits today by 116 unique users